Knowledge Base

Our knowledge base for your self-education

 

Design & Configure

DMVPN Phase 1 Single Hub – EIGRP – Hub example

Technology: WAN
Area: DMVPN
Vendor: Cisco
Software: 12.X , 15.X ISR
Platform: ISR 1800, 2800, 3800, 1900, 2900, 3900, Platforms: 4300, 4400

Traffic Flow:

  • Packet is sent from Spoke1 to Spoke2 network via Hub (according to routing table)
  • Spoke1 has this prefix via HUB tunnel IP for which has also NHRP static mapping
  • Hub routes packet to Spoke2 according to routing table via tunnel

DMVPN Phase 1 and EIGRP:

  • Configure spokes as a stubs
  • Advertise their connected routes
  • Disable split horizon on hub (Spoke to Spoke prefix advertisement)
  • Use next-hop self command (default)

 

DMVPN Phase 1 Single Hub Configuration - EIGRP


R1:
!
!
router eigrp 111
no auto-summary
network 10.1.0.0 0.0.255.255
network 172.16.1.0 0.0.0.255
!
! Tunnel source
!
interface Loopback0
ip address 10.149.1.1 255.255.255.0
!
! VPN network
!
interface Loopback 1
ip address 10.1.1.1 255.255.255.0
!
! mGRE tunnel
!
interface Tunnel0
ip address 172.16.1.1 255.255.255.0
no ip redirects
ip nhrp authentication gmlabs
ip nhrp map multicast dynamic
ip nhrp network-id 111
no ip split-horizon eigrp 111
ip summary-address eigrp 111 10.0.0.0 255.0.0.0
tunnel source Loopback0
tunnel mode gre multipoint
tunnel key 123

 
PreviousNext ?>
 

Newsletter