Knowledge Base

Our knowledge base for your self-education

 

Design & Configure

DMVPN Phase 1 Single Hub – EIGRP – Spoke example

Technology: WAN
Area: DMVPN
Vendor: Cisco
Software: 12.X , 15.X ISR
Platform: ISR 1800, 2800, 3800, 1900, 2900, 3900, Platforms: 4300, 4400

Traffic Flow:

  • Packet is sent from Spoke1 to Spoke2 network via Hub (according to routing table)
  • Spoke1 has this prefix via HUB tunnel IP for which has also NHRP static mapping
  • Hub routes packet to Spoke2 according to routing table via tunnel

DMVPN Phase 1 and EIGRP:

  • Configure spokes as a stubs
  • Advertise their connected routes
  • Disable split horizon on hub (Spoke to Spoke prefix advertisement)
  • Use next-hop self command (default)

 

DMVPN Phase 1 Single Hub Configuration - EIGRP


R2:
!
!
router eigrp 111
no auto-summary
network 172.16.1.0 0.0.0.255
network 10.1.2.0 0.0.0.255
eigrp stub connected
!
interface Loopback0
ip address 10.149.2.2 255.255.255.0
!
interface Loopback 1
ip address 10.1.2.2 255.255.255.0
!
! GRE tunnel
!
interface Tunnel0
ip address 172.16.1.2 255.255.255.0
ip nhrp authentication gmlabs
ip nhrp map 172.16.1.1 10.149.1.1
ip nhrp map multicast 10.149.1.1
ip nhrp nhs 172.16.1.1
ip nhrp network-id 111
ip nhrp holdtime 60
ip nhrp registration timeout 30
tunnel source Loopback0
tunnel destination 10.149.1.1
tunnel key 123

 

Author: Marcin Bialy
 
PreviousNext
 

Newsletter