Knowledge Base

Design & Configure

DMVPN Phase 2 Single Hub – EIGRP – Spoke example

Traffic Flow:

  • Packet is intended to be sent from Spoke1 to Spoke2 network
  • According to routing table Spoke’s2 network is known via its original next hop but it is marked in CEF as incomplete and next hop IP is marked simultaneously as CEF glean adjacency / punt (now, need to perform NHRP resolution) – the NBMA of next hop is unknown, so Spoke1 triggers NHRP resolution to NHS (including next hop of Spoke2, Source of its tunnel, it’s NBMA)
  • In the same time first packet is routed via Hub based on RIB
  • Similar thing is done by Spoke2 when it needs to send packet back to Spoke1
  • NHS responds with NHRP resolution and then CEF is populated as complete and Spokes can communicate directly

DMVPN Phase 2 and EIGRP

  • Advertise spoke’s connected routes
  • Disable split horizon on hub (Spoke to Spoke prefix advertisement)
  • Disable Next hop self feature

 

DMVPN Phase 2 EIGRP Hub - Spoke EXample configuration

 

R2 Spoke, note that tunnel destination command need to be removed because of mGRE behavior:

router eigrp 111
network 10.1.2.0 0.0.0.255
network 172.16.1.0 0.0.0.255
!
interface Tunnel0
tunnel mode gre multipoint

 

R3 Spoke, note that tunnel destination command need to be removed because of mGRE behavior:

 

router eigrp 111
network 10.1.3.0 0.0.0.255
network 172.16.1.0 0.0.0.255
!
interface Tunnel0
tunnel mode gre multipoint

Author: Marcin Bialy
 
PreviousNext
 

Newsletter