Menu

US Region

Grandmetric LLC
Brookfield Place Office
200 Vesey Street
New York, NY 10281
EIN: 98-1615498
+1 302 691 94 10
info@grandmetric.com

EMEA Region

GRANDMETRIC Sp. z o.o.
ul. Metalowa 5, 60-118 Poznań, Poland
NIP 7792433527
+48 61 271 04 43
info@grandmetric.com

UK

Grandmetric LTD
Office 584b
182-184 High Street North
London
E6 2JA
+44 20 3321 5276
info@grandmetric.com

  • en
  • pl
  • DMVPN Phase 3 Single Hub – EIGRP – Spoke example

    Design & Configure

    DMVPN Phase 3 Single Hub – EIGRP – Spoke example

    Traffic Flow:

    • Packet is sent from Spoke’s 1 network to Spoke’s 2 network via Hub (according to routing table)
    • Hub routes packet to Spoke2 but in parallel sends back the NHRP Redirect message to Spoke1 containing information about suboptimal path to Spoke2 and tunnel IP of Spoke2
    • Spoke1 then issues the NHRP Resolution request of Spoke’s 2 NBMA IP address to NHS with destination IP of Spoke’s 2 tunnel, this NHRP Resolution request is sent targeted to Spoke2 via NHS (according to routing table) – it is normal hop by hop NHRP forwarding process
    • Spoke2 after receiving resolution request including NBMA IP of Spoke1 sends the NHRP Resolution reply directly to Spoke1 – Reply does not traverse the Hub!
    • Spoke1 after receiving correct NBMA IP of Spoke2 rewrites the CEF entry for destination prefix – this procedure is called NHRP Shortcut
    • Spokes don’t trigger NHRP by glean adjacencies but NHRP replies updates the CEF

     

    DMVPN Phase 3 and EIGRP

    • Advertise spoke’s connected routes
    • Disable split horizon on hub (Spoke to Spoke prefix advertisement)
    • Enable Next-hop-self feature

    DMVPN Phase 3 EIGRP Hub - Spoke Example configuration

     

    R2 Spoke configuration:

     

    router eigrp 111
    network 10.1.2.0 0.0.0.255
    network 172.16.1.0 0.0.0.255

    interface Tunnel0
    ip address 172.16.1.2 255.255.255.0
    no ip redirects
    ip nhrp authentication gmlabs
    ip nhrp map 172.16.1.1 10.149.1.1
    ip nhrp map multicast 10.149.1.1
    ip nhrp network-id 111
    ip nhrp holdtime 60
    ip nhrp nhs 172.16.1.1
    ip nhrp registration timeout 30
    ip nhrp shortcut
    tunnel source Loopback0
    tunnel mode gre multipoint
    tunnel key 123
    tunnel protection ipsec profile DMVPN_PROFILE
    end

    R3 Spoke configuration:

     

    router eigrp 111
    network 10.1.3.0 0.0.0.255
    network 172.16.1.0 0.0.0.255
    !
    interface Tunnel0
    ip address 172.16.1.3 255.255.255.0
    no ip redirects
    ip nhrp authentication gmlabs
    ip nhrp map 172.16.1.1 10.149.1.1
    ip nhrp map multicast 10.149.1.1
    ip nhrp network-id 111
    ip nhrp holdtime 60
    ip nhrp nhs 172.16.1.1
    ip nhrp registration timeout 30
    ip nhrp shortcut
    tunnel source Loopback0
    tunnel mode gre multipoint
    tunnel key 123
    tunnel protection ipsec profile DMVPN_PROFILE
    end
    POD1_R3#

    Author: Marcin Bialy
     
    Grandmetric