Knowledge Base

Our knowledge base for your self-education

 

Design & Configure

DMVPN Phase 3 Single Hub – OSPF – Spoke example

Traffic Flow:

  • Packet is sent from Spoke’s 1 network to Spoke’s 2 network via Hub (according to routing table)
  • Hub routes packet to Spoke2 but in parallel sends back the NHRP Redirect message to Spoke1 containing information about suboptimal path to Spoke2 and tunnel IP of Spoke2
  • Spoke1 then issues the NHRP Resolution request of Spoke’s 2 NBMA IP address to NHS with destination IP of Spoke’s 2 tunnel, this NHRP Resolution request is sent targeted to Spoke2 via NHS (according to routing table) – it is normal hop by hop NHRP forwarding process
  • Spoke2 after receiving resolution request including NBMA IP of Spoke1 sends the NHRP Resolution reply directly to Spoke1 – Reply does not traverse the Hub!
  • Spoke1 after receiving correct NBMA IP of Spoke2 rewrites the CEF entry for destination prefix – this procedure is called NHRP Shortcut
  • Spokes don’t trigger NHRP by glean adjacencies but NHRP replies updates the CEF

 

DMVPN Phase 3 and OSPF

  • Configure OSPF p2m type (all spokes are aware of whole topology)
  • Advertise spoke’s connected routers
  • Disable split horizon on hub (Spoke to Spoke prefix advertisement)
  • The one of OSPF limitation is single area routes summarization

DMVPN Phase 3 OSPF Hub - Spoke Example configuration

 

DMVPN Phase 3 – OSPF – Spoke configuration example – R2:

 

router ospf 111
router-id 10.1.2.2
area 1 range 10.1.2.0 255.255.255.0
network 10.1.2.0 0.0.0.255 area 1
network 172.16.1.0 0.0.0.255 area 0
 
interface Tunnel0
ip address 172.16.1.2 255.255.255.0
no ip redirects
ip mtu 1400
ip nhrp authentication gmlabs
ip nhrp map 172.16.1.1 10.149.1.1
ip nhrp map multicast 10.149.1.1
ip nhrp network-id 111
ip nhrp holdtime 60
ip nhrp nhs 172.16.1.1
ip nhrp registration timeout 30
ip nhrp shortcut
ip ospf network point-to-multipoint
tunnel source Loopback0
tunnel mode gre multipoint
tunnel key 123
tunnel protection ipsec profile DMVPN_PROFILE

 

DMVPN Phase 3 – OSPF – Spoke configuration example – R3:

 

POD1_R3#sh run | s router os
router ospf 111
router-id 10.1.3.3
area 1 range 10.1.3.0 255.255.255.0
network 10.1.3.0 0.0.0.255 area 1
network 172.16.1.0 0.0.0.255 area 0
 
interface Tunnel0
ip address 172.16.1.3 255.255.255.0
no ip redirects
ip mtu 1400
ip nhrp authentication gmlabs
ip nhrp map 172.16.1.1 10.149.1.1
ip nhrp map multicast 10.149.1.1
ip nhrp network-id 111
ip nhrp holdtime 60
ip nhrp nhs 172.16.1.1
ip nhrp registration timeout 30
ip nhrp shortcut
ip ospf network point-to-multipoint
tunnel source Loopback0
tunnel mode gre multipoint
tunnel key 123
tunnel protection ipsec profile DMVPN_PROFILE

 
Previous?>
 

Newsletter