Knowledge Base

Design & Configure

DMVPN Phase 1 Single Hub – OSPF – Hub example

Technology: WAN
Area: DMVPN
Vendor: Cisco
Software: 12.X , 15.X ISR
Platform: ISR 1800, 2800, 3800, 1900, 2900, 3900, Platforms: 4300, 4400

Traffic Flow:

  • Packet is sent from Spoke1 to Spoke2 network via Hub (according to routing table)
  • Spoke1 has this prefix via HUB tunnel IP for which has also NHRP static mapping
  • Hub routes packet to Spoke2 according to routing table via tunnel

DMVPN Phase 1 and OSPF

  • Configure OSPF point to multipoint network type (next hop behavior)
  • Advertise spoke’s connected routes
  • Set static default routes on spokes into HUB direction via tunnel interface

 

DMVPN Phase 1 Single Hub Configuration - EIGRP

 


R1:
!
!
router ospf 111
router-id 10.1.1.1
network 10.1.1.0 0.0.0.255 area 0
network 172.16.1.0 0.0.0.255 area 0
!
! Tunnel source
!
interface Loopback0
ip address 10.149.1.1 255.255.255.0
!
! VPN network
!
interface Loopback 1
ip address 10.1.1.1 255.255.255.0
!
! mGRE tunnel
!
interface Tunnel0
ip address 172.16.1.1 255.255.255.0
no ip redirects
ip nhrp authentication gmlabs
ip nhrp map multicast dynamic
ip nhrp network-id 111
tunnel source Loopback0
tunnel mode gre multipoint
tunnel key 123
ip ospf network point-to-multipoint

 

Author: Marcin Bialy
 
PreviousNext
 

Newsletter